[TYPO3-50-general] zend_mm_heap corrupted when accessing TYPO3CR

Thomas Fritz fritztho at gmail.com
Thu Feb 19 13:53:36 CET 2009

Can you paste your configure statement? I think had this error on a
previuous alpha of php.

In the meantime - Here is mine: I compiled on gentoo. So you should change
the paths in the configure statement.

./configure '--prefix=/usr/lib/php5.3beta1' '--host=i686-pc-linux-gnu'
'--mandir=/usr/lib/php5.3beta1/man' '--infodir=/usr/lib/php5.3beta1/info'
'--sysconfdir=/etc' '--cache-file=./config.cache' '--enable-cli'
'--enable-cgi' '--with-config-file-path=/etc/php-5.3beta1/cgi-php5'
'--without-pear' '--enable-bcmath' '--with-bz2' '--enable-calendar'
'--with-curl' '--without-curlwrappers' '--enable-exif' '--disable-ftp'
'--with-gettext' '--with-gmp' '--disable-ipv6' '--without-kerberos'
'--enable-mbstring' '--with-mcrypt' '--with-mhash' '--without-mssql'
'--with-openssl' '--with-openssl-dir=/usr' '--enable-pcntl'
'--without-pgsql' '--disable-posix' '--without-pspell' '--without-recode'
'--disable-shmop' '--without-snmp' '--enable-soap' '--enable-sockets'
'--without-sybase-ct' '--disable-sysvmsg' '--disable-sysvsem'
'--disable-sysvshm' '--with-tidy' '--disable-wddx' '--with-xmlrpc'
'--with-xsl' '--enable-zip' '--with-zlib' '--disable-debug' '--enable-dba'
'--without-cdb' '--with-db4' '--disable-flatfile' '--with-gdbm'
'--without-qdbm' '--without-freetype-dir' '--without-t1lib'
'--disable-gd-jis-conv' '--with-jpeg-dir=/usr' '--with-png-dir=/usr'
'--without-xpm-dir' '--with-gd' '--with-imap' '--with-imap-ssl'
'--with-mysql=/usr' '--with-mysql-sock=/var/run/mysqld/mysqld.sock'
'--with-mysqli=/usr/bin/mysql_config' '--without-pdo-dblib'
'--with-pdo-mysql=/usr' '--without-pdo-odbc' '--without-pdo-pgsql'
'--with-pdo-sqlite=/usr' '--with-readline' '--without-libedit'
'--without-mm' '--with-sqlite=/usr' '--enable-sqlite-utf8' '--enable-phar'

Best regards


On Wed, Feb 18, 2009 at 10:00 PM, Peter Beernink <p.beernink at drecomm.nl>wrote:

> Hi list,
> After setting up a new development environment I tried to access the
> TYPO3CR to see if some test data I was working on was available.
> However, when I tried to call the TYPO3CR, I got a blank screen.
> When I checked my Apache access log, the request wasn't logged, so I
> checked the error log.
> There I found that calling the TYPO3CR was causing a 'zend_mm_heap
> corrupted' message.
> As I've installed both PHP5.2 and PHP5.3 (not using them at the same time)
> I was wondering if this might be causing the problem, or that others are
> also having the same problem, before I report it as a PHP bug.
> I'm currently running on this configuration:
> Ubuntu 8.10 (Kernel 2.6.27-11)
> Apache 2.2.9
> PHP 5.3.0b1
> Greetings,
> Peter
> _______________________________________________
> TYPO3-project-5_0-general mailing list
> TYPO3-project-5_0-general at lists.netfielders.de
> http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-project-5_0-general

More information about the TYPO3-project-5_0-general mailing list