[TYPO3-50-general] Problem installing FLOW3

Peter Beernink p.beernink at drecomm.nl
Wed Oct 15 10:03:54 CEST 2008

Hi list,


After attending most of the FLOW3/TYPO3 5 sessions at the T3CON08, I became
quite enthusiastic and wanted to run it myself, to get a better
understanding of 

the techniques used and get more involved in the future in one way or the


However after doing a checkout of the code (the latest revision I checked
out was 1360), I run into some problems during the execution of the install

First of all, it seems that the fixpermissions.sh which is being called from
the install script does not exist.

I've copied it from the BlogExample branch to have that available, but
probably some paths in the script are wrong, as I get the message 


chown: cannot access `Public/Resources/': No such file or directory


But I think that the next problem I run in to is a bigger one.

When the curl action is being executed, it runs for some time and than I
receive an uncaught Exception:


#1220884009: The controller component
"f3::flow3::controller::defaultcontroller" does not exist. (More

F3::FLOW3::MVC::Exception::NoSuchController thrown in file
FLOW3/Classes/MVC/F3_FLOW3_MVC_Request.php in line 160.



Does anyone have any hints on how to proceed from here?


My current system:

Debian 4.0 with PHP5.3a1 compiled on it.

I've chosen to run sqlite as production DB and haven't configured the other
engines for testing purposes.




Peter Beernink

More information about the TYPO3-project-5_0-general mailing list