[TYPO3-mvc] naming issue: prefixedExtensionKey vs argumentNamespace vs prefix vs designator

Jochen Rau j.rau at web.de
Thu May 7 11:44:00 CEST 2009


Hi Bastian.

> [ ] (argument)Namespace (could be confused with PHP namespaces)
> [ ] prefix (..it's not really a prefix)
> [ ] designator (that's how it's called in lib/div - but is that a good 
> name for it?)
> [ ] better ideas?
> [ ] /is there an official name for array parameters in URIs?/

In our discussion on Skype yesterday, I voted for the official name for 
array parameters (not knowing it ;-)).

After a (short) night, I'd like to propose two additional solutions:

Let's assume we have a signature of the URIFor() method in both cases like

public function URIFor(
	$actionName = NULL,
	$arguments = array(),
	$controllerName = NULL,
	$extensionName = NULL,
	$pluginKey = NULL,
	$pageUid = NULL,
	array $options = array()
	) {}

This sticks as close as possible to FLOW3.

1) Then we can say

<f:actionlink actionName="baz" controllerName="bar" 
extensionName="myext" pluginKey="foo" pageUid="123">link</f:actionlink>

which results in:

<a 
href="index.php?id=123&tx_myext_foo[action]=baz&tx_myext_foo[controller]=bar">link</a>

And

<f:actionlink actionName="baz">link</f:actionlink>

should render the same link, if "bar" is the current controller and 
"foo" the current plugin.

2) If we are able to set $options = array('additionalParams' => 
'tx_myext_foo[bar]=baz') and merge the additionalParams with the 
arguments. the fluid tag will be

<f:actionlink options="{additionalParams: 
'&tx_myext_foo[bar]=baz'}">link</f:actionlink>

which also results in:

<a 
href="index.php?id=123&tx_myext_foo[action]=baz&tx_myext_foo[controller]=bar">link</a>


Maybe we can join the two solutions for complete freedom of usage.

Regards
Jochen


More information about the TYPO3-project-typo3v4mvc mailing list