[TYPO3-mvc] naming issue: prefixedExtensionKey vs argumentNamespace vs prefix vs designator

Bastian Waidelich bastian at typo3.org
Thu May 7 09:43:43 CEST 2009


Good morning,

while working on the link view helpers I'm having troubles to find a 
good name for the argument that specifies the "namespace" of the query 
parameters...

currently it works like this:

<f:actionlink actionName="foo">link</f:actionlink>
generates:
<a href="index.php?id=123&tx_myextension_myplugin[action]=foo">link</a>

If you want to create a link to another extension (or another plugin of 
the same extension) it would be (at the moment):

<f:actionlink actionName="foo" 
prefixedExtensionKey="tx_otherextension_otherplugin">link</f:actionlink>
resulting in:
<a 
href="index.php?id=123&tx_otherextension_otherplugin[action]=foo">link</a>

I called it "prefixedExtensionKey" as I couldn't find a better name. But 
actually it's totally wrong because it's rather the extension _name_ 
plus the plugin-suffix. Besides it could be anything else you want to 
prefix your arguments with..

So what do you think of:

[ ] (argument)Namespace (could be confused with PHP namespaces)
[ ] prefix (..it's not really a prefix)
[ ] designator (that's how it's called in lib/div - but is that a good 
name for it?)
[ ] better ideas?
[ ] /is there an official name for array parameters in URIs?/

I know, this seems like a trivial issue. But links and the URIHelper 
will be central components of Extbase & FLOW3 and developers will be 
using it all over the place thus the signatures should be proof. So 
please help ;)

Bastian


More information about the TYPO3-project-typo3v4mvc mailing list