[TYPO3-seminars] The frontend editing form does not get displayed

Andreas Becker ab.becker at web.de
Tue Jun 1 08:20:55 CEST 2010


Hi Oliver

we included the static template in the root page of the seminars branch and
now also on the page itself but still receive the follwoing message:

*Configuration check warning:*
The static template is not included. This has the effect that important
default values do not get set. To fix this, please include this extension's
template under *Include static (from extensions)* in your TS template.
When that is done, please empty the FE cache and reload this page.
*The configuration check for this extension can be disabled in the extension
manager.*

-----
We have emptied cache many times already but no change.

Actually we receice another error after clearing cache:

In the table fe_groups, the column tx_seminars_reviewer does not have a TCA
entry.

#0
/home/sites/site6/html/typo3conf/ext/oelib/class.tx_oelib_DataMapper.php(347):
tx_oelib_DataMapper->getRelationConfigurationFromTca('tx_seminars_rev...')
#1
/home/sites/site6/html/typo3conf/ext/oelib/class.tx_oelib_DataMapper.php(302):
tx_oelib_DataMapper->isOneToManyRelationConfigured('tx_seminars_rev...')
#2
/home/sites/site6/html/typo3conf/ext/oelib/class.tx_oelib_DataMapper.php(289):
tx_oelib_DataMapper->createRelations(Array,
Object(tx_seminars_Model_FrontEndUserGroup))
#3
/home/sites/site6/html/typo3conf/ext/oelib/class.tx_oelib_DataMapper.php(272):
tx_oelib_DataMapper->fillModel(Object(tx_seminars_Model_FrontEndUserGroup),
Array)
#4 [internal function]:
tx_oelib_DataMapper->load(Object(tx_seminars_Model_FrontEndUserGroup))
#5 /home/sites/site6/html/typo3conf/ext/oelib/class.tx_oelib_Model.php(371):
call_user_func(Array, Object(tx_seminars_Model_FrontEndUserGroup))
#6 /home/sites/site6/html/typo3conf/ext/oelib/class.tx_oelib_Model.php(273):
tx_oelib_Model->load()
#7 /home/sites/site6/html/typo3conf/ext/oelib/class.tx_oelib_Model.php(342):
tx_oelib_Model->get('tx_seminars_def...')
#8
/home/sites/site6/html/typo3conf/ext/seminars/Model/class.tx_seminars_Model_FrontEndUserGroup.php(133):
tx_oelib_Model->getAsList('tx_seminars_def...')
#9
/home/sites/site6/html/typo3conf/ext/seminars/Model/class.tx_seminars_Model_FrontEndUserGroup.php(143):
tx_seminars_Model_FrontEndUserGroup->getDefaultCategories()
#10
/home/sites/site6/html/typo3conf/ext/seminars/Model/class.tx_seminars_Model_FrontEndUser.php(154):
tx_seminars_Model_FrontEndUserGroup->hasDefaultCategories()
#11
/home/sites/site6/html/typo3conf/ext/seminars/Model/class.tx_seminars_Model_FrontEndUser.php(169):
tx_seminars_Model_FrontEndUser->getDefaultCategoriesFromGroup()

----------
etc ..

---------
after reloading the same page again we get the first error message about the
missing template again.

Database Analyser Compare we have done but no changes at all

We reinstalled seminars but also here no changes until now.
We reinstalled also oelib, seminars and no changes

Andi




On Mon, May 31, 2010 at 7:21 PM, Oliver Klee
<typo3-german-02 at oliverklee.de>wrote:

> Hi,
>
> Am 30.05.2010 08:52, schrieb Andreas Becker:
> > We are facing problems to get the frontend editing form displayed. We
> > entered all values in flexform and have set also the following values in
> the
> > main Seminars TS template
> >
> > TS-Template (shortcut to List view)
> > --- LIst
> > ------ Detail
> > ... (etc. likein manual)
> > --- FeEditing
> >
> > --------------
> >
> > page.includeCSS.file2 =fileadmin/pagetemplates/css/subpage_events.css
> >
> >
> > ### SEMINARS ###
> > plugin.tx_seminars {
> > # Do not touch this variable! This is needed for checking whether this
> > static template has been included correctly.
> > isStaticTemplateLoaded = 1
>
> Um, have you actually included the static template, or just copied all
> values from setup.txt?
>
> You need to include the static TS template, and only set the values
> which are are going to change. Particularly, you should never set
> isStaticTemplateLoaded as this variable is used to detect whether the
> static template has been included (as the naming might suggest), and
> setting it manually renders the detection useless.
>
>
> Oliver
> --
> Certified TYPO3 Integrator | TYPO3 Security Team Member
> _______________________________________________
> TYPO3-project-seminars mailing list
> TYPO3-project-seminars at lists.typo3.org
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-project-seminars
>


More information about the TYPO3-project-seminars mailing list