[TYPO3-english] Show usergroup and fe_user info

bernd wilke t3ng at bernd-wilke.net
Mon Nov 11 14:16:43 CET 2013

Am 11.11.13 13:36, schrieb Miguel:
> Thank you for your time Bernd.
> Once again you're right, a "required=1" solved the issue. Now, in what
> concerns to "tx_itypoexpiringfegroups_groups" i think it's all fine
> However is still not working the "20" lines, where fe_groups are
> rendered from the normal usergroups column. Even if "
> tx_itypoexpiringfegroups_groups" has no value, nothing is shown in the
> frontend...
> Any idea why?

propably because your selection is wrong.

debuggung the generated query is not easy.
you may activate sql-debugging and invalidate the query on purpose so 
you get the query displayed. after removing your own mistke you can feed 
phpmysql (or similar) with the query to inspect it.

my guess would be:
select.andWhere.field = usergroup
will not give you the usergroups of current user.

let's see:
10.data = TSFE:fe_user|user|tx_itypoexpiringfegroups_groups
gave us the expiring usergroups. why not use the same construct to get 
the normal usergroups?

     select.andWhere.data = TSFE:fe_user|user|usergroup

and so it may contain multiple groups use in (list) instead of Equality:
     select.andWhere.wrap = uid in (|)
and so the field may be empty [1] which would result in an sql-error:
     select.andWhere.required = 1
     ifTrue.data = TSFE:fe_user|user|usergroup

[1] by default this field is required and could not be empty if entered 
by hand in the BE


More information about the TYPO3-english mailing list