[TYPO3-english] T3 6.0 and headerData (not appearing)

Markus Klein klein.t3 at mfc-linz.at
Thu Feb 21 08:52:56 CET 2013


Hi!

> 
> Hi Again!
> 
> Fair enough.  The thing is my deprecated log was getting so huge I turned it off.  (I'm kidding).
Even though you're kidding here, this is indeed a problem I'm aware of. But usually it suffices to activate it for a short time and simply visiting the page and/or modify something in BE.
It will catch most of the deprecated stuff already.
This would have also told you that the readLLXMLfile() method is deprecated. See below.

> 
> I used "broke" in quotes as I fully realize I'm missing lots in this upgrade.  I did it about two months ago and I've just found work
> arounds for some things.
> 
> That said here are a few of the problems I'm running up against.
> 
> CoolURI - this url use to work just fine (I've disabled CoolURI - and no, Dmitri.... RealURL isn't much better in my install ;):
> http://www.sushibynature.com/blog/featured-articles/view/fish-chart-sustainability-pcbs-
> mercury/ff63f3eb99e09bd3d24eae86ff839b8b.html
> 
> (this is set:  config.simulateStaticDocuments = 0)

I can't say much about this problem, but might still be some configuration issue.
 
> 
> further:
> mm_forum stopped working
> comments stopped working
> 
> A couple other extensions cause some havoc - for instance when I go to add a new content container I get a blank page. The only way
> I can create new content is by doing a copy/paste of an existing container.  I get this error when I try:
> 
> [Wed Feb 20 20:00:49 2013] [error] [client ] PHP Fatal error:  Call to undefined method
> TYPO3\\CMS\\Core\\Utility\\GeneralUtility::readLLXMLfile() in
> ..../websites/typo3/www/typo3conf/ext/facebook_socialplugins/pi1/class.tx_facebooksocialplugins_pi1_wizicon.php on line 65,
> referer: http://www.sushibynature.com/typo3conf/ext/templavoila/mod1/index.php?id=7

As you can clearly see, the problem is the facebooksocialplugins extension using a removed method.

> 
> I could go on (and probably will later).
> 
> I've been tempted to downgrade to 4.7 but really don't want to.  At the same time I'm left not able to recommend an upgrade to 6.0
> for the dozens of commercial T3 sites I've developed over the last 5+ years.

I have to admit that I only upgraded one single tiny production installation. The others still lack proper versions of the extension in use, to avoid such hazards you experienced.

> 
> regards,
> Doug
> 


Kind regards
Markus






More information about the TYPO3-english mailing list