[TYPO3-english] T3 6.0 and headerData (not appearing)

Douglas La Farge douglas.lafarge at gmail.com
Thu Feb 21 02:05:46 CET 2013


Hi Again!

Fair enough.  The thing is my deprecated log was getting so huge I turned it off.  (I'm kidding).

I used "broke" in quotes as I fully realize I'm missing lots in this upgrade.  I did it about two months ago and I've just found work arounds for some things.

That said here are a few of the problems I'm running up against.

CoolURI - this url use to work just fine (I've disabled CoolURI - and no, Dmitri.... RealURL isn't much better in my install ;):
http://www.sushibynature.com/blog/featured-articles/view/fish-chart-sustainability-pcbs-mercury/ff63f3eb99e09bd3d24eae86ff839b8b.html

(this is set:  config.simulateStaticDocuments = 0)

further:
mm_forum stopped working
comments stopped working

A couple other extensions cause some havoc - for instance when I go to add a new content container I get a blank page. The only way I can create new content is by doing a copy/paste of an existing container.  I get this error when I try:

[Wed Feb 20 20:00:49 2013] [error] [client ] PHP Fatal error:  Call to undefined method TYPO3\\CMS\\Core\\Utility\\GeneralUtility::readLLXMLfile() in ..../websites/typo3/www/typo3conf/ext/facebook_socialplugins/pi1/class.tx_facebooksocialplugins_pi1_wizicon.php on line 65, referer: http://www.sushibynature.com/typo3conf/ext/templavoila/mod1/index.php?id=7

I could go on (and probably will later).

I've been tempted to downgrade to 4.7 but really don't want to.  At the same time I'm left not able to recommend an upgrade to 6.0 for the dozens of commercial T3 sites I've developed over the last 5+ years.

regards,
Doug

On Feb 20, 2013, at 5:39 PM, Markus Klein <klein.t3 at mfc-linz.at> wrote:

> Hello!
> 
> Things didn't really break in 6.0: If you had a look in the deprecation log in your 4.7 installation, you should have found the lines telling you that HTML is deprecated and its scheduled removal. ;-)
> 
> But... you're welcome.
> 
> Kind regards
> Markus
> 
> 
>> -----Original Message-----
>> From: typo3-english-bounces at lists.typo3.org [mailto:typo3-english-bounces at lists.typo3.org] On Behalf Of Douglas La Farge
>> Sent: Thursday, February 21, 2013 1:32 AM
>> To: TYPO3 English
>> Subject: Re: [TYPO3-english] T3 6.0 and headerData (not appearing)
>> 
>> Hello!
>> 
>> Well that was simple.  Thank you for that.
>> 
>> Though it does make me wonder if the half a dozen other things that "broke" with 6.0 upgrade are that simple.
>> 
>> thanks again.
>> 
>> regards,
>> Doug
>> 
>> On Feb 20, 2013, at 5:22 PM, "Markus Klein" <klein.t3 at mfc-linz.at> wrote:
>> 
>>> Hi!
>>> 
>>> Try to replace HTML with TEXT.
>>> HTML has been deprecated.
>>> 
>>> Kind regards
>>> Markus
>>> 
>>>> -----Original Message-----
>>>> From: typo3-english-bounces at lists.typo3.org
>>>> [mailto:typo3-english-bounces at lists.typo3.org] On Behalf Of Douglas
>>>> La Farge
>>>> Sent: Thursday, February 21, 2013 1:17 AM
>>>> To: typo3-english at lists.typo3.org
>>>> Subject: [TYPO3-english] T3 6.0 and headerData (not appearing)
>>>> 
>>>> After upgrading a t3 4.7 site to t3 6.0 TScript like the following
>>>> now longer is output <head>
>>>> 
>>>> page.headerData.2500 = HTML
>>>> page.headerData.2500.value (
>>>> 
>>>> <script type="text/javascript">
>>>>  $("document").ready(function() {
>>>>  	$("li a[href$=.pdf]").css("color", "#002222");
>>>>  });
>>>> </script>
>>>> 
>>>> )
>>>> 
>>>> footerData gives the same (lack of) results.
>>>> 
>>>> I've done numerous web searches but as of yet have turned up nothing
>>>> in regards to this.  Can someone point me in the right direction on how to solve this?
>>>> 
>>>> thank you,
>>>> Doug
>>>> _______________________________________________
>>>> TYPO3-english mailing list
>>>> TYPO3-english at lists.typo3.org
>>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english
>>> 
>>> _______________________________________________
>>> TYPO3-english mailing list
>>> TYPO3-english at lists.typo3.org
>>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english
>> 
>> _______________________________________________
>> TYPO3-english mailing list
>> TYPO3-english at lists.typo3.org
>> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english
> 
> _______________________________________________
> TYPO3-english mailing list
> TYPO3-english at lists.typo3.org
> http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english



More information about the TYPO3-english mailing list