[TYPO3-english] Strange issue with tiny, cache, html5

Richard Davies richard at ocular.co.nz
Thu Nov 10 01:12:18 CET 2011

Hi all,

Just informing anyone if they run into the same issue. We recently started
using doctype html5 for some of our new sites. We found that in subpages,
even though the template object browser was stating the doctype as html5,
the doctype was being printed as <!DOCTYPE html PUBLIC "-//W3C//DTD HTML
4.01 Transitional//EN">. I spent hours trying to figure it out. The issue
went away when I set the pages as 'nocache' and on one sub-page, but not
others. Came straight back when nocache was taken off. Tried clearing all
the caches, but it persisted.

This is a server that the last developer/site admin set up, so I had no
idea what he'd done. I checked all the extensions, couldn't find any that
did anything. It worked if I copied the install to our test server. Tried
updating to 4.5 (its an old install, worried about breaking some random
extension) and it didn't work. Was considering debugging the typo3 core on
our live site when I eventually realised that the tag on the subpages <meta
name="generator" content="HTML Tidy for Linux/x86 (vers 6 November 2007),
see www.w3.org"> might mean something. Unfortunately read the Tidy as
Tiny... eventually realised it was actually Tidy and found that Tidy was
working on the live server and not the test server.
$TYPO3_CONF_VARS['FE']['tidy'] in localconf was set to 1, it didn't
recognise the html 5 declaration on the live site so it replaced it with a
'correct' doctype. Setting $TYPO3_CONF_VARS['FE']['tidy'] to 0 fixed it.

Hope this helps somebody in the future

More information about the TYPO3-english mailing list