[TYPO3-english] t3blog: Fatal error: Cannot redeclare class tx_t3blog_tcemain

jumping-blueberry - steffi jumping-blueberry at gmx.net
Thu Aug 5 00:26:44 CEST 2010


Hello Typo3-experts,

I'm still struggling with t3blog.
After some google-research I found out, that the feature which didn't  
work for me is called "IRRE".

The problems with IRRE are:

Minor problems
1. Problems with "Umlaute"
This has already been reported as a bug:
http://bugs.typo3.org/bug_view_advanced_page.php?bug_id=15337
However I also had it in Version 4.3.3 (the author says downgrading  
would help)
2. RTE is not included in the IRRE-subelements
Only a normal Textarea is shown.
I use tinymce_rte
I used tinyrte before and had the same problem.

Main problem
(I already reported it before but now I've done some more research)
When I create a content it is not connected with the post.
However the content is visible over "List" (Liste) and as normal  
website-content on below the blog.
The table tx_t3blog_post_content_mm is completly empty.
However the content of the old posts is being connected even without  
any entries in this table.
In the table tx_t3blog_post the posts without content have a "0" in  
the field "content".
In the tt_content of the old Posts there is an entry in the field  
"irre_parenttable": tx_t3blog_post which is empty in the new posts.
Through my resarch, I found this solution:
http://typo3.org/documentation/document-library/extension-manuals/ 
t3blog/0.9.1/view/1/6/#id2504496
I'm not sure if this describes my problem properly.
My content-elements are displayed after and not before the blog.
But I tried to modify the solution so it fits to my layout:

page.10 < plugin.tx_t3blog_pi1.myblog
page.bodyTag = <body id="blog">

temp.normalColumnWithoutIRRE = CONTENT

temp.normalColumnWithoutIRRE {
     table = tt_content
     select {
        where = colPos = 0 AND irre_parentid = 0
        orderBy = sorting
        languageField = sys_language_uid
      }
}

page.10.subparts.INHALT < temp.normalColumnWithoutIRRE

However when I tried this, suddenly this message was displayed:
Fatal error: Cannot redeclare class tx_t3blog_tcemain in /xxx/cms/ 
typo3conf/ext/t3blog/hooks/class.tx_t3blog_tcemain.php on line 32
It appears when I try to save anything - even pages that have nothing  
to do with t3blog or changes in the TEMPLATE.

I should mention that I also tried to integrate a modification into  
this file which now causes the error based on "defaulcontent".
But I completely removed it again.
The change had been in the method  processDatamap_preProcessFieldArray 
() and didn't affect the include_once-part in any way...
I downloaded the t3x-file again and imported the extension again.
So I suppose all files have been overwritten. (Is this correct or do  
I misunderstand the system here?)

Meanwhile I even had to run the installtool again as I removed DAM  
(without removing all modules depending on it) and couldn't get into  
the backend anymore.

Something else:
I removed the extension several times to reinstall it again.
After one of these re-installations t3blog was suddenly completely in  
German - Which is good, as this is the language the t3version runs with.
As I was quite desperate, I didn't pay attention to every step -  
which I of course regret now - so I can't say what I changed to get  
this.

Details on my System:
Typo3 4.4.0
relevant extensions:
t3blog 0.9.1
dam 1.1.5
pagebrowse 1.1.0
typoscripttools 0.0.2

Can anyone please help me?
Meanwhile I'd even be happy if I could go back to the just not  
working IRRE and start again from there.
How can I restore the  initial state of an extension?

Thanks in advance

:o)


More information about the TYPO3-english mailing list