[TYPO3-english] mnogosearch: Can't create tx_mnogosearch_indexconfig with type Records

Dmitry Dulepov dmitry at typo3.org
Wed Dec 3 10:27:10 CET 2008


Hi!

Mario Reatti wrote:
> i have the same problem but when i run :
> php -q /home/.../.../public_html/typo3/cli_dispatch.phpsh mnogosearch -v 3
> -w
> 
> i get this type of error:
> 
> ...
> .....
> {sqldbms.c:2476} Query: CREATE TABLE dictFF (url_id int(11) DEFAULT '0' NOT
> NULL, secno tinyint unsigned DEFAULT '0' NOT NULL, word varchar(255) DEFAULT
> '' NOT NULL, intag blob NOT NULL, KEY url_id (url_id), KEY word_url (word))
> 
> {sql.c:678} Query: SELECT rec_id, url FROM server WHERE rec_id=-44936156
> 
> Log has not been opened
> DB err: MySQL driver: #2002: Can't connect to local MySQL server through
> socket '/var/run/mysqld/mysqld.sock' (2) - /tmp/mnogosearch-MNGIXE:28:
> 
> MySQL driver: #2002: Can't connect to local MySQL server through socket
> '/var/run/mysqld/mysqld.sock' (2)
> 
> 
> I set the extension correctly (with slash...), the db was created and the
> user used in ext config has the correct privileges.
> but the tables and data was not created from command line.
> 
> Any idea?

This is not the same problem because there is nothing about indexing config in your message...

It appears that mnogosearch indexer cannot connect to mysql. You need to contact your admin to solve it. Most likely /etc/mysql.ini has wrong location of the mysql socket in the [client] section.

-- 
Dmitry Dulepov
TYPO3 core team
In the blog: http://typo3bloke.net/post-details/how_to_enable_memcached_cache_in_typo3_43/
My TYPO3 book: http://www.packtpub.com/typo3-extension-development/book


More information about the TYPO3-english mailing list