[TYPO3] CAN login to BE but still CANNOT login to Install Tool

Walter Jenner walter.jenner at fh-joanneum.at
Mon Jul 30 13:34:54 CEST 2007

Hi Everyone!

I found a way how I can login to the Install Tool:

If I just enter the password into the login form and submit it, then
nothing happens.

If I pass the password via the url (eg.
everything is OK. I just have to pass the password once, because
afterwards it is retrieved from the cookie.

I have no idea, why the cookie is not set, if I just use the login form.
Php.net says that the setcookie function only works if there was no
output before calling the function, but if that would be the problem,
every typo3 user should have this problem, or?

But, anyway this looks like a bug of typo3 for me -maybe a bug which is
only occuring under certain circumstances...

Best Regards,

Walter Jenner schrieb:
> Walter Jenner schrieb:
>> Pierre Rouwens schrieb:
>>> Hi Walter,
>>> Give a try with :
>>> Pierre
>>> Walter Jenner a écrit :
>>>> Hi Everybody!
>>>> I have a strange problem, with my Typo3 Installation on an IIS Server
>>>> (Wasn't my choice). I cannot login neither BE nor to Install-Tool.
>>>> * I think the Server is IIS 5 on Win2003.
>>>> * mySql is 5.0.22
>>>>     sql mode =
>>>>     (should I try MYSQL4 for the sql-mode??)
>>>> * php is 5.2.0
>>>>     sessions are working, I've tested that already
>>>> * typo3 is 4.1.2
>>>> The database user has all rights for the typo3 database.
>>>> The BE-users I'm trying are existing in the database-table.
>>>> The install tool password I'm trying is correct, as I checked this in
>>>> the localconf.php. That I don't see the usual hint ("The password you
>>>> just tried has this md5-value: ") when I try to login, is also an sign
>>>> for me that the password is correct.
>>>> I set doNotCheckReferer = 1 as well as lockIP = 0
>>>> Another information which might be important: During the installation
>>>> empty tables where created, so I inserted a dump from the local
>>>> installation.
>>>> Last not least: JavaScript and Cookies are enabled.
>>>> Has anyone an idea? Any help would be apreciated, thanks in advance
>>>> Walter
>> Thanks for your answer Pierre!
>> As I've tried on my development server, the option "STRICT_TRANS_TABLES"
>>   prohibits the login to the backend. Without that option, it works fine!
>> So I hope my (Inhouse) Server-Admin removes this option from the my.cnf ...
>> Anyway, the problem that I cannot login to the Install Tool seems to
>> remain, as I can login on the development-server even with
>> "STRICT_TRANS_TABLES". So I guess, removing it on the live-server will
>> not make the login possible. But I will check this later.. step by step.
>> Thanks again and best regards,
>> Walter
> Hi,
> removing STRICT_TRANS_TABLES from the sql-mode helped. I can login to
> backend now, but I still cannot login to the Install Tool.
> Any ideas?
> Best regards,
> Walter

More information about the TYPO3-english mailing list