[TYPO3] Urgent help needed

rocky rockyo at max-source.com
Wed Sep 13 08:53:55 CEST 2006


Christopher wrote:
> Hello,
> 
> On 9/12/06, rocky <rockyo at max-source.com> wrote:
>> rocky wrote:
>> > Hey list,
>> >
>> > I do not know why one of my live website designed by typo3 version 
>> 4.0.1
>> > give me the following warning:
>> >
>> > Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL
>> > result resource in
>> > /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on
>> > line 801
> 
> <huge snip>
> 
> Several pieces of advice for when you're seeking help first:
> 
> 1. Post small, RELEVANT samples of error messages. If you have 200
> lines of the same or similar errors, there is no need to include ALL
> of them (think how much bandwidth you waste sending this much junk to
> thousands of list subscribers!)
> 
> 2. Do NOT post the same message a) to multiple lists, or b) to the
> same list after only a very short period of time. There's the
> bandwidth issue again, plus it's just plain annoying.
> 
> 3. Provide some INFORMATION! Really, what do you expect anyone to tell
> you to do about such generic errors? When did they start? What was the
> last thing you did before they started? What have you tried to do
> about the problem so far? Did it help? Did it make the problem worse?
> We know nothing about the problem because you have told us NOTHING.
> The best anybody can do is guess at this point.
> 
> Please read the following guidelines about asking for help on
> technical mailing lists:
> 
> http://www.catb.org/~esr/faqs/smart-questions.html
> 
> Now, to your problem:
> 
> The problem is with an sql query, right? This much is obvious from the
> error messages. This gives you a few good options for debugging the
> problem:
> 
> 1. Check your webserver's error logs--do they say anything helpful? If
> there are specific errors that you don't understand, post them to the
> list--this is the kind of information that may be useful.
> 
> 2. Roll back any changes you've made to the database recently to see
> if the problem disappears. In practice this can be achieved by simply
> de-activating recently installed extensions (which will not then query
> the db). Repeat as necessary.
> 
> 3. Add the following line somewhere to localconf.php (this item could
> stand to be better documented--it's hard to find):
> 
> $TYPO3_CONF_VARS['SYS']['sqlDebug'] = 1;
> 
> Once you've done that, go to the page where the problem occurs in the
> BE and switch to the List module. You'll get a debug table showing the
> actual mysql errors. This should probably allow you to pin down the
> extension or component that's at the root of the problem.
> 
> 
> -Christopher

Thank you very much!

Ok before I got this problem. I logged in to the back end as admin and 
under list module clicked on the global icon preceding page. And I got 
some sillillar error I think I really can not remember. and after that I 
switch to the Draft space and them my brower shutdown. I tried to log 
into the backend but I could not do that with the error message on my 
screen which are posted in following email of this thread.


Thanks in advance!
Rocky



More information about the TYPO3-english mailing list