[TYPO3] Urgent help needed

Nagita Karunaratne Nagita.k at gmail.com
Wed Sep 13 06:28:56 CEST 2006


rocky wrote:
> rocky wrote:
>> rocky wrote:
>>> Hey list,
>>>
>>> I do not know why one of my live website designed by typo3 version 
>>> 4.0.1 give me the following warning:
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>>> result resource in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>>> line 801
>>>
>>> Warning: Cannot modify header information - headers already sent by 
>>> (output started at 
>>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php:801) 
>>> in 
>>> /home/maxsour/public_html/typo3_src-4.0.1/typo3/sysext/cms/tslib/class.tslib_fe.php 
>>> on line 2826
>>>
>>> Can any of you give me a hint please!
>>>
>>> Rocky
>> I Can not even able to log into the back end now. When I try I got 
>> this error:
>>
>>
>> Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
>> result resource in 
>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php on 
>> line 801
>>
>> Warning: Cannot modify header information - headers already sent by 
>> (output started at 
>> /home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php:801) 
>> in /home/maxsour/public_html/typo3_src-4.0.1/typo3/index.php on line 473
>>
>> But I can log into the configuration platform by going to 
>> www.mydomain.com/typo3/install/index.php though.
>>
>> Please help me!
>>
>> Thanks,
>> Rocky
> I found this bug report at http://bugs.typo3.org/view.php?id=3794
> 
> And He/She says
> "Because there is nothing in the database which can be selected througth 
> the select statement, made by exec_SELECTquery(). Than there is nothing 
> to sql_fetch_assoc() so you get an error. Problem can be sloved by 
> useing the @-sign. I report this because i've seen more functions where 
> the same problem can be found."
> 
> Can any of you give me some direction on his proposal of using the 
> @-sign. Please?
> 
> Thanks a lot!
> Rocky
> 
I really have no idea but maybe you can look in line 801 and 473.

/home/maxsour/public_html/typo3_src-4.0.1/t3lib/class.t3lib_db.php:801) 
in /home/maxsour/public_html/typo3_src-4.0.1/typo3/index.php on line 473



More information about the TYPO3-english mailing list