[TYPO3] Typo 3.8 password error reduex

Steinhilber, Carl carl_steinhilber at mentor.com
Tue Mar 14 00:54:06 CET 2006

Using Typo 3.8.1 on Windows 2000 with Apache 2.0.55, PHP 4.4.2 and MySql
5.0.19. No ImageMagick or GDlib yet.
Fresh install of Typo for evaluation (I've actually wiped everything
clean and reinstalled several times now during this troubleshooting).
Used the 1-2-3 version of the install tool.
Tables compare fine.
I can login to the Install Tool (changed password and relogged in), but
can NOT login to the BE interface.
I just keep getting the
Your login attempt did not succeed. Make sure to spell your username and
password correctly, including upper/lowercase characters.
error that's been discussed here a couple of times.
Tried to create new "admin" users via the Database Analyser in the
Install Tool. All attempts report "user created", with the correct
information. But using those admin logins also fail.
I've tried copying the hashed password directly to the admin record.
I've tried manually inserting a new admin record.
Someone mentioned that advanced http.conf options were giving them some
problems... so I backed out the http.conf to a default install, serving
out of /htdocs, etc... just http.conf.default with the PHP modules
added, and that's it.
No matter what I do, I can't login to the BE.
When I do a COMPARE of the tables in the Database Analyser, I get
"Table and field definitions should be updated - There seems to be a
number of differencies between the database and the selected SQL-file.
Please select which statements you want to execute in order to update
your database"
And it seems to need to change nearly every field in every table to NOT
ALTER TABLE be_groups CHANGE uid uid int(11) unsigned NOT NULL
	Current value: int(11) unsigned auto_increment	

But checking all the ALTER TABLE statements, and clicking "Write to
Database" doesn't seem to fix anything (just refreshes the page with the
same differences listed).
Not only that, but when I DUMP the table info from Navicat, the create
statement in the .sql definitely includes the NOT NULL for all fields.
When I compare the tables against $TCA, I get "Extra tables in the
database" and "Extra fields in the database". I did not add or alter
anything from the fresh install. It appears that Typo is having trouble
sensing that the fields are actually set to NOT NULL in the tables.
I manually ran the /typoconf/database.sql file, and received no errors.
But still get the alerts in the COMPARE functions.
I've tried logging in via Firefox and IE.
Anybody have any ideas?
Thanks in advance,

More information about the TYPO3-english mailing list