[TYPO3] tt_news not rendering anything in 4.0b2 or rc1 for me?

Neil Bertram neil at tasmanstudios.co.nz
Sun Mar 12 04:07:58 CET 2006

Hi all!

I originally had a very simple tt_news setup on 3.8.0 working fine, but 
when I decided to try 4.0b2 the tt_news extension was no longer 
compatible. Now that I'm on rc1 I decided to try the 2.2.40 version 
linked from this list to get my news page back, but alas it's not working!

 From what I can see, the class.tx_ttnews.php file isn't ever included 
(putting a die() at the top of it doesn't have any effect, even after 
clearing the FE cache), but the plugin is inserted.

I tried making a new rootlevel page with just tt_news on it, but still 
nothing (with no TS setup other than one of the default templates), and 
this is the source that comes out for a "SEARCH"-type (or any other 
type) tt_news plugin:

<!--  CONTENT ELEMENT, uid:55/list [begin] -->
		<a id="c55"></a>
		<!--  Plugin inserted: [begin] -->
		<!--  Plugin inserted: [end] -->
	<!--  CONTENT ELEMENT, uid:55/list [end] -->

It almost looks like TYPO3 can't actually locate the plugin? I noticed 
TemplaVoila just said "Plugin: 9" instead of News, but the classic page 
module shows it up as "News"...

I tried inserting other plugins, and they're working fine...

I've tried downgrading to 4.0b2, but the output was exactly the same.

Any ideas?


More information about the TYPO3-english mailing list