[TYPO3] Report: Error 500 - ID Problems with Typo3

Benjamin Mack bmack at kirix.com
Thu Jul 27 13:28:53 CEST 2006

Hey Rudy & Dmitry,

that was it. When I dumped the local database (with phpmyadmin) I didn't 
check the "take autoincrement value".

Thanks again guys for great and fast replies! Really awesome list and 
people on it!


Rudy Gnodde wrote:
> Hello Benni,
> I have run TYPO3 installations on several different "limited" shared
> hosting accounts without any of these problems. And this doesn't look
> like a memory problem.
> The problems you are describing sound more like the uid fields aren't
> auto incremented. And probably not a primairy key either (since they're
> suppose to be unique and it would give an error if you try to insert a
> record with a key that already exists). You might want to check that.
> Regards,
> Rudy Gnodde
> WIND Internet
>> -----Oorspronkelijk bericht-----
>> Van: typo3-english-bounces at lists.netfielders.de 
>> [mailto:typo3-english-bounces at lists.netfielders.de] Namens 
>> Benjamin Mack
>> Verzonden: donderdag 27 juli 2006 12:37
>> Aan: typo3-english at lists.netfielders.de
>> Onderwerp: [TYPO3] Report: Error 500 - ID Problems with Typo3
>> Hey,
>> an interesting thing happened.
>> I got a typo3 (4.0) installation on a Alturo Webmaster (4 
>> bucks a month / www.alturo.de) and everything went fine (they 
>> even allow mod_rewrite) with the installation.
>> But after a while my editor told me that he always gets an 
>> Error 500 in the "Page Tree" frame on the page / view / list 
>> items after he created a new page. I was shocked, because I 
>> thought alturo's package was limited.
>> I tried to bring in technical support from alturo and the guy 
>> said "yeah, we recommend that you shouldn't typo3 with our 
>> webmaster package since it needs a lot of memory", looks like 
>> a script limit is in there.
>> Anyway I wanted to create a testuser "tester" for the support 
>> guy. I did this with the "User Admin" which worked fine until 
>> I pressed the "Create" button in the user-creation-form. I 
>> was logged out of the typo3 system. I logged in again but 
>> every time I clicked on the "User Admin" 
>> module, I was logged out.
>> Strange, I thought but I tried to login with the new "tester" 
>> user which did not work at all. I checked the be_users table 
>> with an external phpmyadmin and I found out that the new 
>> "tester" user was actually created and everything *except* 
>> that the be_user had the UID "0". Hmm, I changed it to the 
>> next available number (here: 3) and after that I could log 
>> into Typo3 with that user.
>> So, but my Error 500 problem with the page tree still 
>> existed. I then checked the pages table and found out that my 
>> editor created a new page which also had the ID "0". That's 
>> why the SQL stmt in the pagetree frame
>>   always "crashed".
>> Looks like this is a reference problem inside the core when 
>> using a "limited" shared host. Should this be reported to the 
>> devs? Maybe we can get Typo3 running on more systems with 
>> less performance / less memory?
>> --
>> greetings,
>> benni.
>> -SDG-
>> _______________________________________________
>> TYPO3-english mailing list
>> TYPO3-english at lists.netfielders.de
>> http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-english
> _______________________________________________
> TYPO3-english mailing list
> TYPO3-english at lists.netfielders.de
> http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-english

More information about the TYPO3-english mailing list