[TYPO3] Indexing external files with indexed search

Steven Bagshaw steven.bagshaw at unv.org
Fri Feb 3 14:13:04 CET 2006

Thanks for the tip!

Funnily enough, I just tried that - by hacking the extension - but it still
didn't work.

I tried surrounding the file name with quote marks - works for pdfinfo, but
not for pdftotext. The latter does not seem to like having the file name in
quotes, followed by the temp file name.

So, these work

c:/Webtools/pdftotext.exe -f 1 -l 3 -enc UTF-8 -q

c:/Webtools/pdfinfo.exe "C:/WWW/cms/fileadmin/kp/2005spread/Toolbox/Common
Country Programming Workshop Agenda.pdf"

But this doesn't

c:/Webtools/pdftotext.exe -f 0 -l -enc UTF-8 -q
"C:/WWW/cms/fileadmin/kp/2005spread/Toolbox/Common Country Programming
Workshop Agenda.pdf" C:/WWW/cms/typo3temp/\Typ553.tmp

(note the temp file name at the end). Same results from command line too. I
guess pdftotext is having its own problems with the space char.


"Bjoern Kraus" <krausbn at php.net> wrote in message
news:mailman.1.1138970847.19108.typo3-english at lists.netfielders.de...
> Hi Steven!
> > Does anyone here have a record of the fix for Windows files with spaces
> > them?
> Perhaps you can use the old fashioned "c:/progra~1/..." trick (long
> files and folders have a 8-byte representation).
> Regards
> Bjoern

More information about the TYPO3-english mailing list