[TYPO3] Typo3 4.0 "insert records" not working - Solved!

Katja Lampela katja.lampela at lieska.net
Sat Apr 8 21:39:42 CEST 2006


Katja Lampela wrote:
> Ingmar Schlecht wrote:
> 
>> Hi Katja,
>>
>> Katja Lampela wrote:
>>
>>> I'm updating my 3.8.1 sites to 4.0 and everything has worked like charm.
>>> But now I encountered strange behavior; where ever there is a Insert
>>> record content element (and the reference records seem to work alright,
>>> and I've tried to reconnect and save etc.) I get an error message:
>>>
>>> NO entry in the $TCA-array for the table "tt_address". This means that
>>> the function enableFields() is called with an invalid table name as
>>> argument.
>>
>>
>>
>> The tt_address extension is not included in the core anymore.
>>
>> Thus you need to get it from the Extension Repository and install it 
>> again.
>>
>> http://typo3.org/extensions/repository/search/tt_address/1.0.4/
>>
>> cheers
>> Ingmar
> 
> 
> Thank you so much for your reply Ingmar.
> 
> This is indeed another issue I have. I've been trying to get the 
> repository full list open but I can't - only in the mode where the 
> "enable unsupported extensions" is off and there the tt_address can't be 
> found. If I enable unsupported extensions and try to import all the 
> extensions, I get a completely blank view. And I've tried to check and 
> uncheck all kinds of combinations in the settings. So I don't know if it 
> could be a bigger problem like php-version or mysql ..?
> 
> Thank you any way for this information! I will do it the first thing if 
> I get the repository working.
> Cheers, Katja

This last issue was resolved by former thread about CR3 and extension 
repository and about php.ini modification. Thank you list! Following is 
the quote:

"Gert Kaae Hansen schrieb:

 > When i search of a extention i get the following error Fatal error: 
Fatal error: Maximum execution time of 30 seconds exceeded in 
/home/www/tyksak/typo3/mod/tools/em/class.em_xmlhandler.php on line 112


 > Dose any of you have any clue how to fix this.


yes, tune up the maximum execution time for php scripts in your php.ini 
or wherever you configure your php, for example:

max_execution_time = 120     ; Maximum execution time of each script, in 
seconds
max_input_time = 90     ; Maximum amount of time each script may spend 
parsing request data
memory_limit = 128M      ; Maximum amount of memory a script may consume 
(8MB)


Axel. "



More information about the TYPO3-english mailing list