[TYPO3] Typo3 4.0 install: problem with extension that requires the symlinks

Franz Holzinger franz at fholzinger.com
Sat Apr 8 12:23:59 CEST 2006


Hello Pieter,
> 
> So, i made a copy of tslib to C:/apache/xampp/htdocs/t4/ and ... YES,
> the backend was working.
> 
> But, the fronted now pops up with an error:
> Fatal error: Cannot redeclare class tslib_pibase in
> C:\apache\xampp\htdocs\t4\typo3\sysext\cms\tslib\class.tslib_pibase.php
> on line 0
> 
> I can uninstall beko_debugster or I can change the source of
> beko_debugster but there are probably more extensions with the same
> problem.  What is the best way to prevent these problems?  What should I
> do to simulate the pre-4.0 symlinks (on a WinXP and probably also on a
> Linux system)?
> 
Because of this error message it seems to be impossible to get those
extensions running with symlinks under Windows. Try it out under LINUX.

Otherwise the extension authors need to use the TYPO3 constants to get
the Path to tslib.

require_once(PATH_tslib."class.tslib_pibase.php");

So change this line in the extension.


- Franz




More information about the TYPO3-english mailing list