[Typo3] Extension Manager Problems

KEN STEVENS kstevens at wvdep.org
Thu Jun 9 15:11:43 CEST 2005


in the install.txt file for Typo 3  under the extension manager heading you find>

THE EXTENSION MANAGER
=====================
......

NOTE - there is a known bug at present...when using TYPO3 on Windows together with the Apache ISAPI module,
you will get errors when trying to download from the repository. Windows and Apache in CGI mode works OK.
.......

The error I get is 

Warning: fopen(http://ter.typo3.com/?id=t3_extrep&tx_extrep[T3instID]=N%2FA&tx_extrep[TYPO3_ver]=3.8.0&tx_extrep[PHP_ver]=4.3.4&tx_extrep[returnUrl]=http%3A%2F%2Flocalhost%2Fquickstart-3.7.0%2Ftypo3%2Fmod%2Ftools%2Fem%2Findex.php%3Fter_connect%3D1%26ter_search%3D&tx_extrep[gzcompress]=1&tx_extrep[user][fe_u]=*******&tx_extrep[user][fe_p]=*******&tx_extrep[cmd]=currentListing): failed to open stream: Bad file descriptor in C:\apache\htdocs\quickstart-3.7.0\typo3\t3lib\class.t3lib_div.php on line 2099

I am using:
  windows XP pro
  Apache/2.0.48 (Win32)
  PHP/4.3.4 
  TYPO3_VERSION: 3.8.0

Ken

**************************************************************

Michael Courcy karatepla at yahoo.fr wrote:

Can you show this reference, please ?
I use the EM on apache 2 with no particular probleme ....

Michael.

KEN STEVENS wrote:

>There is reference to a known bug in 3.8.0 about the Extension Manager with Apache2 using  ISAPI and that it works in CGI mode.
>
>How do I change Apache to CGI mode so I can use the Extension Manager.
>
>Feel free to tell me how dumb I am and where the answer already is.
>
>Ken Steven



More information about the TYPO3-english mailing list