[Typo3] how to debug tt_address insertion (dmail)

Felix Natter felix.natter at ldc.de
Tue Jul 26 09:53:55 CEST 2005


I am having problems with adding gender information to the directmail
subscription dialog. I tried to post to typo3.projects.direct-mail
but it looks like I am getting no reply.

Basically the problem ist that I did these things:
- add a field gender to tt_address (char(1) not null)
- add a field to the array in class.t3lib_dmailer.php
- modify the dmail subscription template to include a
  <input type="text" name="FE[tt_address][gender]">-block

But when I enter "m" for gender and submit, the new db record has an empty
gender (tt_address.gender='').

I tried to set $debugOutput=true in t3lib/class.t3lib_db.php, but I get no error
How can I debug this (where is the dmail_subscription code that fills in
the tt_address record)?


here is what I did in detail:
I added gender information to the tt_address table:
  alter table tt_address add column gender char(1) not null;
and changed the array in class.t3lib_dmailer.php so that it reads:
  $rowFieldsArray = explode(',', 'uid,name,title,email,phone,www,address,company,city,zip,country,fax,firstname,gender');
and finally I added a <input type="text" name="FE[tt_address][gender]">-block
to fe_admin_dmailsubscrip.tmpl:
<!--###SUB_REQUIRED_FIELD_gender### begin
	This is shown only if the form is submitted and the field is configured to be "required" and at the same time not filled in.
	The syntax is of the comment 'name' is: 	SUB_REQUIRED_FIELD_[enter-the-field-name-here]
	<font color=red><strong>Dieses Feld bitte Ausfuellen!</strong></font><BR>
<!--###SUB_REQUIRED_FIELD_gender### end -->
<input type="text" name="FE[tt_address][gender]">

Felix Natter

More information about the TYPO3-english mailing list