[Typo3] Can one install Typo3 on a shared server with an FTP program?

Bill Alexy bill at psiberware.com
Wed Jul 13 20:58:21 CEST 2005

Sly Sylvester wrote:
> For the past 5 days I have been going through the
> whole documentation and mailing list but could not
> find any answer to my problem. 
> My question is, can one install Typo3 on a shared
> server uploaded with an FTP program?
> I am on a shared server and my host is 1&1.
> I downloaded the QuickStart ZIP version 3.8.0 and
> unzip to my pc and then uploaded it to my shared
> server with an FTP program(FlashFXP) e.g.
> http://www.mytestsite.com/typo3/.
> Then started my browser and pointed to
> http://www.mytestsite.com/typo3/typo3/install/ and I
> went through the rest of the insatllation without any
> problem, I thought.
> But when I clicked on the (1: Basic Configuration) the
> error appeared in RED: 
> typo3temp/ directory does not exist.
> And on clicking on (5: typo3temp/) and there appear
> the error clearly.
> typo3temp/ not writable!
> You must make typo3temp/ write enabled before you can
> proceed with this test.
> And I tried to enter the BE and after entering the
> default username: admin and password: password, there 
> comes the page blank with the following error: 
> ERROR: PATH_site + "typo3temp/" was not a directory!
> and I could not enter the real BE page.
> As said earlier, I went through the whole mailing
> lists read a hand full of the documentations but came
> across a very few who had the same problem in a
> different way. And the problem was not really solved.
> Please could somebody tell me how to solve this
> problem. Or how best to install the typo3 on a shared
> server. I am not really sure where exactly the problem
> lies.
> Sylva.
> PS:
> My host's PHP Memory limit is 40MB. 
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around 
> http://mail.yahoo.com 
Hi Sylva,
Using your FTP program or web admin change the permissions on your typo3 
installation files and folders to write read and execute enabled. Here's 
a link that shows you how

In the change File Attributes dialog box Check evey checkbox or type 777 
in the "Manual" field

This link should be a help also:


More information about the TYPO3-english mailing list