[Typo3] Problem with folder move... File not written to disk! Write permission error in filesystem?

Gilles Deacur tronno22556 at gmail.com
Mon Dec 12 15:09:28 CET 2005


Gilles Deacur wrote:
> Christopher wrote:
> 
>> Hi,
>>
>> On 12/11/05, Gilles Deacur <tronno22556 at gmail.com> wrote:
>>
>>> Roy Beck wrote:
>>>
>>>> Gilles Deacur wrote:
>>>>
>>>>
>>>>>>>
>>>>>>>
>>>>>>> What I had to do is download all files to my harddrive and then
>>>>>>> upload to a different position in the website.  Filezilla apparently
>>>>>>> lacks a feature that just moves the files around on the site itself.
>>>>>>>
>>>>>>> I went into the install tool and my open_basedir is : 
>>>>>>> open_basedir: off
>>>>>>>
>>>>>>> This is the exact same setting in the old site location.
>>>>>>>
>>>>>>
>>>>>> I fired up my CuteFTP and did a "move" from the old location to the
>>>>>> new location, so I imagine it would have automatically overwritten
>>>>>> the old permissions and ownerships.  Still get the same error upon
>>>>>> logging into the backend.
>>>>>>
>>>>>
>>>>> Furthermore, I checked the file ownership, and my uploads defaulted
>>>>> them to my username, whereas on the old site, a lot of them were
>>>>> marked as "nobody".  Does the fact that they are marked as
>>>>> "myusername" vs. "nobody" have any sort of impact?
>>
>>
>>
>> Yes.
>>
>> This is not really a Typo3-specific issue, but rather a problem for
>> your host (or whoever has 'root' or sufficient priveleges on your
>> webserver anyway) to solve. Nobody here can really do much to help you
>> out except to confirm that, yes, the download-reupload sequence caused
>> the problem.
>>
>> If your site is on a linux box--I don't really know, in enough detail
>> to help you out, how it works on Windows--the user that executes php
>> scripts (often this user is called 'nobody') must be able to execute
>> scripts and read and write to certain files and directories. At the
>> same time, it's usually necessary for the account owner's username to
>> be able to read and write many or all of the same files and
>> directories. This can be done by making both users members of the same
>> group.
>>
>> Since your host is unlikely to allow your user to be a member of the
>> group that the 'nobody' user belongs to, the solution will probably be
>> to change the appropriate files so that their _group_ is 'nobody' (or
>> whatever).
>>
>> You'll need your host to do this (unless you're running a dedicated
>> server or VPS), but what needs to be done is something like the
>> following series of commands (broken up for readability):
>>
>> [Assuming you're in 'public_html' or equivalent...]
>>
>> chgrp -R nobody typo3conf
>> chgrp -R nobody typo3temp
>> chgrp -R nobody fileadmin
>> chgrp -R nobody uploads
>>
>> [Assuming you're in the directory containing the directory 
>> typo3_src-3.8.1]
>>
>> chgrp -R nobody typo3_src-3.8.1
>>
>> You will need to make sure that file permissions are correctly set on
>> the first set of files; if the webserver (i.e. 'nobody') is to be able
>> to write to those directories (_definitely_ necessary in the case of
>> typo3conf, typo3temp and uploads), they will likely have to have
>> permissions of 775 (i.e. since the second '7' gives read, write and
>> execute priveleges to the _group_ that the files belong to).
>>
>> The source files (second group) should be fine with permissions set to
>> 755, _unless_ you need to install extensions to the global location
>> (typo3/ext/) in which case, you'll have to set the permissions of that
>> directory appropriately.
>>
>>
>> -Christopher
> 
> 
> I clipped and pasted this email for my hosting support to look at.  They 
> changed the owners and it works great now!
> 
> Thanks for your help on this one.  This support network is great!

I still have a problem:

I tried uploading a template for a site into /fileadmin/ and got this error:


Warning: 
move_uploaded_file(/home2/sunshine/public_html/fileadmin/gisbits/template-gisbits-2.htm): 
failed to open stream: Permission denied in 
/home2/sunshine/public_html/typo3/t3lib/class.t3lib_div.php on line 2989

Warning: move_uploaded_file(): Unable to move '/tmp/phpmpe7HP' to 
'/home2/sunshine/public_html/fileadmin/gisbits/template-gisbits-2.htm' 
in /home2/sunshine/public_html/typo3/t3lib/class.t3lib_div.php on line 2989

Warning: Cannot modify header information - headers already sent by 
(output started at 
/home2/sunshine/public_html/typo3/t3lib/class.t3lib_div.php:2989) in 
/home2/sunshine/public_html/typo3/template.php on line 601


Errors:
	1: Uploaded file could not be moved! Write-permission problem in 
"/home2/sunshine/public_html/fileadmin/gisbits/"?

I notice that I have filesettings in the new fileadmin as owner/group: 
myname (?)  [My actual user name and an actual question mark for the 
group] for all files within fileadmin.

The old settings were:
myname / myname for _temp_, user_upload, and for one file and the rest 
(8 folders) are set to: nobody (?) [The name NOBODY with an actual 
question mark for the group]

Is there a reason some were marked with my name and others were set to 
nobody?

Is there a "proper" setting for all these folders so I can have my host 
chown these to the right group?  Or are some of one type and others of 
another type?

Thanks.



More information about the TYPO3-english mailing list