[Typo3] Problem with folder move... File not written to disk! Write permission error in filesystem?

Roy Beck rabeck at islanders.ca
Sun Dec 11 14:42:04 CET 2005


Gilles Deacur wrote:
> Sorry for the numerous "hijacked" posts.  Everytime I post this it 
> appears as a hijack to another post in my reader.  I'm just hoping it's 
> showing as a new thread this time:
> 
> 
> 
> 
> I just moved my typo3 installation from a subfolder to the root of my site.
> 
> I checked all file permissions and when I try to log into the back end 
> of the new typo3 location, I get this:
> 
> Warning: 
> fopen(/home2/sunshine/public_html/typo3temp/llxml/misc.xml_058ff4fc51.default.iso-8859-1.cache): 
> failed to open stream: Permission denied in 
> /home2/sunshine/public_html/typo3/t3lib/class.t3lib_div.php on line 2117
> ERROR: File not written to disk! Write permission error in filesystem?
> 
> I even checked the /typo3conf/localconf.php for anything that would 
> cause a problem (no changes were made to the file) and I even logged 
> into the installation tool to see if anything was obviously wrong, but 
> there weren't any warnings set in the installation tool.
> 
> The front end appears to be working, but I can't log into the backend.
> 
> Please help.
> _______________________________________________
> Typo3-english mailing list
> Typo3-english at lists.netfielders.de
> http://lists.netfielders.de/cgi-bin/mailman/listinfo/typo3-english
> 
I had the same problem after I switched hosts. In my case, it was a 
combination of permissions and ownership, plus a problem with the 
open_basedir being incorrectly set. Since you have already checked 
permissions, check the ownership of the files and the setting of 
open_basedir in phpinfo.

Roy Beck
rabeck at islanders.ca
http://www.islanders.ca



More information about the TYPO3-english mailing list