[Typo3] PHP 4.4.1 issue with install tool and DB compare

mohamed boujataoui mohamedlistings at gmx.net
Fri Dec 2 17:42:13 CET 2005


Hi,

As far as I understand these things, I'm facing problems too, because 
the hoster of my managed server (schlund.de) updated PHP to 4.4.1 (and 
MySQl 4.0.25).
Now I get this error in BE in Typo3 3.8.0/.1 (but not in 3.6.2):

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL 
result resource in xyz/typo3_src-3.8.1/t3lib/class.t3lib_db.php on line 741

(DB compare didn't solve problem)

And PHPAccelerator also isn't any longer working (and I can't solve 
compiling problems of other accelerator like Turck or Eaccelerator due 
to missing rights for the "make install" command and knowledge how to 
configure "make install" with allowed directories for installation)

regards,
mohamed boujataoui

Karsten Dambekalns schrieb:
> Hi.
> 
> I am trying to install TYPO3 3.8.1 on a server with PHP 4.4.1 (and MySQL
> 4.0.25, IIRC).
> 
> This is a ZIP-file install, due to only FTP being available (I hate this,
> usually I have shell access on the servers I work with, grr!).
> 
> Now when I go to the install tool and say compare in the db analyzer, it
> first suggests to set up a few tables; afterwards there are 12 tables in
> the db. Hm, some are missing. compare again, now we get the suggestion to
> add those tables again and at the *same screen* the suggestion to remove
> all those tables... ?!?!?
> 
> When trying to import the whole database.sql from the dummy package, it just
> says "no tables found". But on compare it at least installs 29 tables. I
> cannot login to the BE anyway, though.
> 
> I have set up a whole lot of TYPO3 instances so far, and never seen this. So
> I suspect this to be caused by the 4.4.1 version of PHP - can anyone
> confirm this?
> 
> Regards,
> Karsten



More information about the TYPO3-english mailing list