[TYPO3-dev] pass FE session data

Mauro Lorenzutti mauro.lorenzutti at webformat.com
Thu Oct 12 08:51:01 CEST 2006


Hi Franz,

>> In the mailing list I found this solution:
>> 
>> "http://www.mydomain.com/index.php?id=10&FE_SESSION_KEY=".
>> rawurlencode($GLOBALS["TSFE"]->fe_user->id."-".md5($GLOBALS["TSFE"]->fe_user->id."/".$GLOBALS["TYPO3_CONF_VARS"]["SYS"]["encryptionKey"]));
>> 
>> I have the correct $GLOBALS["TSFE"] object but I still see the login page. Any idea?
>> 
> the $GLOBALS["TYPO3_CONF_VARS"]["SYS"]["encryptionKey"] will only work
> if both sites have the same encryption key. Otherwise you must hardcode
> this or get somehow the internal encryption key of the other site.


Thank you for your answer.

This is the case: I'm working in the same site so the encryption key
is the same. However the link above brings me to the login page. It
could be a cookie problem? Do I have to pass more parameters?

P.S. Due to the fact I received your answer I think that my email has
been forwarded to the mailing list members, also if I didn't receive
it... Strange behaviour: if I send a question to the english mailing
list I receive my email.

Best regards,
 Mauro Lorenzutti


e-mail:  mauro.lorenzutti at webformat.com

---------------------------------------------------------
WEBFORMAT srl | Corte Europa, 12 | I-33097 SPILIMBERGO PN
     Tel +39-0427-926.389  --  Fax +39-0427-927.653
       info at webformat.com  --  www.webformat.com
---------------------------------------------------------




More information about the TYPO3-dev mailing list